Preferences - General

The Preferences - General dialog box is one of the pages that appears when you choose the Edit > Preferences command on the main menu bar. It allows you to set global preferences for InstallMate.

Dialog fields and options

This dialog box contains the following fields and options.

Attribute Description
Recent Projects list remembers this many projects

Enter the number of recently used projects that InstallMate shows on the File > Open Recent Project menu. The maximum number is 32.

Note that this option has no effect on the Recent projects list on the Project manager page; that list always shows up to 32 projects.

Reload last project on startup Check this box to let InstallMate reload the most recently opened project when it starts up; clear it to start with the Project manager page each time. This is the same option as Open the most recent project on startup on the Project manager page.
Allow multiple instances Check this box to allow multiple instances of InstallMate to be open at the same time; clear it to restrict it to a single instance. Multiple instances are useful if you regularly work with several InstallMate projects at once, for example to copy and paste between projects.
Clear Recent Projects list Click this button to empty the list of recently opened projects that InstallMate maintains. It affects both the File > Open Recent Project menu and the Recent projects list on the Project manager page.
Reset warning messages Click this button to re-enable message boxes that were hidden after you clicked Don't show again when the message was shown. See Message reference for a list of these messages.
Automatic update checks

Check this box to have InstallMate check for program updates automatically; clear this field to perform only manual update checks.

Note: Before InstallMate downloads and installs a new version, it will inform you and allow you to cancel the update.

Check for updates every this many days Set the desired number of days between automatic program update checks.
Check updates now

Click this button to perform an update check immediately, without regard for the automatic update check settings. This is identical to the Help > Check for Updates command on the main menu bar.

Note: Before InstallMate downloads and installs a new version, it will inform you and allow you to cancel the update.

Show file installation/removal state

Check this box to add installation (green arrow) and removal (red arrow) state icons to the files on the Files and folders page; clear it to omit those icons.

Note: This option takes effect after the next project reloading. If necessary, close, then reopen the current project to see its effect.